2K Battery Doorbell occasionally can't show live view on Echo Show

Hi all,

I have the 2K Battery Doorbell with Chime (model is called 2C doorbell I think)
I noticed once every few days Alexa’s Echo Show 5 can’t show the live view feed from the doorbell, informing that “Hm, I’m having trouble reaching null”. Also when this happens, the routine created to automatically show the live view on doorbell press doesn’t work too, and I hear the same strange error message on the Echo Show 5.

Only after I power cycle the Chime unit (resetting the doorbell itself doesn’t work), then the live feed works again.

Is there anyone else experiencing the same problem? I’ve tried removing the doorbell and chime from Alexa, remove and readd the Eufysecurity Alexa skill, but none of that prevents the issue from occuring again after a few days.

I’m having the same problem with the 2k indoor camera. But can’t find a fix.

I’ve power cycled everything, un/reinstalled skill, camera, and apps.

I’m also having the exact same issue? “Hm, I’m having trouble reaching null” and not being to to stream or see my doorbell for the past two days?

Had this same issue, same error “null” for the past two days? Tried restarting Homebase, removed Eufy Security skill and RE-enabled in the Alexa app, tried various setting changes but all my cameras and doorbell will not show on any of my echo shows? Strangely I am able to arm, disarm my Homebase via voice on any Alexa show? This really is so frustrating!

Has anyone found any solutions to address this?

1 Like

Eufy acknowledged that there was a problem. It has now been rectified, everything seems to be working! I am now able to stream on Amazon Echo, Google Hub and via the Eufy web portal!

1 Like