Cam 2c won’t pair to Homebase2

Bought a Cam 2 system working fine. Decided to add a Cam 2c camera to the setup . But the problem is that it won’t add to my HomeBase2 (blue lights flashing when pairing on both Devices as it should. Camera charged up ??
Any help please

1 Like

Sorry to learn about the issue with your device! Please be assured we always stand behind our products and want to make this right for you.

I am so sorry to hear that the cameras cannot be added, regards to this issue, please help to confirm the following information:

-If you can hear a beep when you press the sync button on the camera.
-If the LED light turns to red when you charge the camera.

If the issue still persists, please send us a video showing you trying to set up the camera. We just need to see what you’re seeing.

Please send us the information to support@eufylife.com, we will have the engineer to look into this case for you with our best efficiency.

I have just bought the system and 2 cameras are blinking and not pairing to home base. Please help.

I have the same problem, I bought the video doorbell 2k battery powered with the homebase 2 then an additional cam2c but it won’t connect to the homebase 2. Can anyone help me with this?

I have had my Eufy cameras and doorbell system that I purchased September 9, 2020. So far one camera of the 2 has been problematic and is frustrating the hell out of me. It has gone offline and then after I follow the instructions YOU posted on YOUR website the camera still does NOT work. Either help me resolve the problem or send me a new camera! I HAVE BEEN SITTING RIGHT NEXT TO BOTH MY ROUTE AND HOMEBASE THAT ARE ON THE SAME DESK!! I HAVE HAD NO PROBLEMS WITH THE OTHER CAMERA AND THE DOORBELL CAM. I AM BEGINNING TO THINK I SHOULD HAVE STAYED WITH RING!

I am having the same issue. I bought a 4 cam 2c with Homebase2. Blue lights and add failed

I am having the same issue. From the start one camera and one doorbell are funtioning well. The second camera lost connection after several days and could not be reconnected.
Tried 2 new cameras (replaced by retailer).
The only possible way to connect either of them to the home base was when they were connected to the home base via the charging cable. Both times the camera functioned for a short time (about an hour) and then lost connection. Tried several times to reconnect but failed.