Camera Offline - who's getting the same issue?

Hi Guys,

I’ve been having issues with my cameras since i got them and installed them, one of the camera would always go offline and i couldnt figure out why, I was getting great connection to the homebase also. after constant trial and error I think I have found the issue…

even though the cameras connect directly to the homebase, they use the wifi channel that your router/modem is currently using, maybe it gets this info from the initial connection to the router for setup? My Telstra modem was auto selecting channel 9 for wifi, which meant the homebase was also using channel 9 for the cameras, regardless if the the home base was connected cable or in repeater mode it would use the same channel as the modem.

I changed the wifi channel to 1 on my modem and the camera came online straight away, I havent had it go offline since! I would suggest checking what channel your modem/router is currently using and change it to a channel with less interference (1,6,11)

let me know if this helps for you also


So I own the wireless doorbell / Homebase 2 set
At the same time I ordered the eufycam 2c add on camera.

The doorbell work’s really good.
No complaints about that.
The add on eufycam 2c keeps getting offline after a day or so.

if I hit the sync button on the camera, it pops back online.
It almost looks like it is powering down ???

Things I have tried so far.

  • reboot homebase, no luck
  • reboot entire network, no luck
  • set my network to the 2.4 band, no luck it actually was worse.

Things to test out for now.

  • set a fixed wifi channel.
  • ad constant power to the cam.


My network is 3 Apple airport routers to make 1 gaint wireless network.
It is up and running for almost 3 years now without any problems.

I had the same problem, this morning all the cameras are off.
I uninstalled everything and reset everything.
Lots of problem to re-register all the cameras, after finally getting there, 1 hour after all the cameras are offline again
Nothing has been changed on the network infrastructure

1 Like

I’m getting Camera Offline issue as well. However, I stood in front of the doorbell cam and I got Person Alert notification, which means the hardware is fine, home network is fine. The issue is on the Eufy AWS server. For now just sit back and relax.

Edit: I just restarted my doorbell camera and Playback/Live view working again.


I updated my doorbell cam to the latest firmware and the going offline problem has not happened again for the past 6 days… keeping fingers crossed.

1 Like

Same problem here. Changed the channel of the wifi and problem solved!

Change the wifi channel of your router

I contacted Eufy support and they changed something in their server. Now it is solved

1 Like

I have the same issues. I have the eufy home base with 4 camera, just bought and installed a week. Working fine originally, but since last night updated Iphone OS, the camera keep offline… tried to repair… and it went to offline again now… shit… please help

1 Like

I have the same issue. It started after about 10 months but has repeated several times in the past few days. I have not contacted Eufy yet but will. I have reset and repaired and the issue persists.

1 Like

same. randomly will go offline and of course no knowledge it went offline so i think my property is secure but it is not

1 Like

Same issue started two days ago. I have the battery powered 1080p doorbell that just goes offline with no notification. Sync button on the doorbell or chime does nothing. Using the software restart function for the chime does nothing. I have to unplug the chime, bring the doorbell in the house and attach a charging cable to it and then plug the chime back in and eventually, the system re-syncs and all is good. Battery level on the doorbell is fine (over 70%) when this happens. It is very frustrating and upsetting to know that this thing just goes offline at any time with no notification and unless i boot up the app, I don’t know about it.

Hi guys, I had similar issues. Rebooted, reconnected, reset, nothing worked. But, after deleting lots of previous recordings I got stuff back online. Perhaps it will do the trick for you all as well. Give it a try.

I constantly had one 2c camera (of 3) going off-line (one nearest WiFi extender). Problem seems to be router as came back on after resetting router. Some have suggested changing the chanel to 1. Need to look into it more before I try due to my extender set-up.

Eh… What? The 2c cams connect through the homebase. How would resetting the router affect connectivity between the homebase and only one of the cameras? Did you test on WiFi or mobile data?

Continuing the discussion from Camera Offline - who's getting the same issue?:

I am having same issue with eufyCam2 :… please add camera or sensor.
I clicked the sensor for few seconds meter from the home base ,and all ok.after half an hour, same issue happens again,
Any help will be appreciated. Thanks

Eufy cam2c constantly going off line and having to reboot


Same problem here, and nothing from above helps. The cameras have worked without problems until the last update from december 2020.

1 Like

Same issue here. The same camera keeps dropping out. The system worked as expected for about 3 days, but it was a Christmas gift that was only recently installed so it can’t be returned.

Has anyone had any luck resolving this? As mentioned by a previous poster I can’t see how changing the wifi channel fixes anything when the homebase is the device that communicates with cameras

Ever since I added my Indoor Cam P&T to homekit, I’ve noticed that I’m getting more “Camera is offline” errors. What’s worse is that the camera disconnects at random times so I cant pin-point what exactly is causing it.

I’ve done all of the usual troubleshooting such as restarting modem/router, restarting Apple TV (homekit hub), restarted camera but nothing seems to work.

I’ve already posted to the Apple forums about my issue and they gave me the usual answers of making sure the Eufy app is up to date and make sure I have the latest version of iOS. At this point, it seems like the problem is that the Eufy app is not talking correctly with Homekit and/or vice versa but of course, neither side will admit fault.

However, the ONLY reason I’m even using Homekit at all is because it’s the only solution for geofencing at the moment since Eufy’s geofencing is a JOKE. But this is getting old…