Cannot connect to application server eufy

I bought in January 2022 Anker Eufy Video Doorbell 2K black (Battery-Powered) + Home base 2. It worked till april very well, but last 3 months we have problem, cant connect to application server and for last 4days its that problem permanent. I;ve tried to reinstall app, or reset wifi connection, but nothing work. Can you give me some advise please?

1 Like

I’ve had this type of issues as well and eufy customer support would just copy and paste the same troubleshooting all the times (restart phone, reinstall app, reset device etc) and nothing worked. I did my own research and after changing channels in my 2.4ghz wifi connection (my router set the channels automatically) I did it manually and changed it to channel 1. After this no more issues and the camera works faster. Find a way to change it yourself. Try first with 1, if not working change it to 6 or 11, good luck!


Had same issue, error messages trying to stream to Echo, Google Hub and Eufy web portal. Contacted Eufy, support said the usual, check settings, etc. Was told all Eufy servers was working fine. Everything worked prior to the four days. I escalated my case. Eufy customer support manager acknowledged that there was a back-end issue that they are trying to resolve. I received another email two days ago, the issues are now fixed! Thanks Eufy!

1 Like