Eufy 3 cam pack not syncing

Hey everyone,

Just became the owner of a 3 cam pack and homebase 2 (the eufycam 2 pro package).

The installation went pretty okay for 2 of the 3 cams. Those are installed and working normally. The third cam refuses to connect to the homebase and fails to be added as a device.

It fails to sync up in whatever order (as I had tried it as the first one, then as the second one, and ultimately as last). It has been reset (sync button five times in succession) and I have rebooted the homebase multiple times as well. The cam is fully charged.

So far, no results. The cam seems to be working fine in so far as beeping, blue LED, beeping multiple times when reset.

Is there any idea or input on this issue? I can’t return the single camera because it has been bought in a set. So that would mean I’d have to uninstall everything and get it replaced whole.

Thanks in advance for any ideas!

As two cams work fine, I assume the third one is close enough to the homebase when syncing. If not, try holding it real close to the homebase.

As for the returns, if its bought through official eufy channels, a solution could be created for you, but contact support@eufylife.com to be sure.
If the set is bought from a third party seller, eufy and the seller will probably suggest returning the entire set ‘for repairs’. I personally hope for you that the former applies to you… :confused:

It is, I’ve had it at all kinds of distances when syncing just to try it out and make sure. No luck. Not when it’s on top of the homebase, not on the prescribed distance and not from further away.

That sucks. So what you can do now is to write to support (support@eufylife.com). Maybe they have a suggestion to fix it. If not, and your pack is not bought from eufy directly, decide whether you want to bring it in for repairs at the third party reseller.

1 Like