Eufy Security app stuck on Iphone

Hi , I have a Eufy video doorbell and Eufy Security app on my iphone. Yesterday when someone rang my door bell app alerted me and when I clicked on the notification app got stuck and blocked my iphone completely. Couldnt kill the app or force shutdown my phone. When I tried to force shutdown it notified all emergency contacts and called 911. After explaning my phones malfunction tried to drain the battery to shutdown my phone. I was able to get a hold of second phone and found a way to force restart a Iphone by clicking volume up and volume down and hold power button. Only then I was able to gain control of my phone again. Whatever caused this issue should be fixed quickly and thank god I didnt need gps.

Exact Sam thing happened to me today. Since last night I was without phone and also had to identify myself with the 911 associate. Yes

Same thing happened today.
This is ridiculous. Iphone froze when I opened the eufy app. I couldn’t access anything. Tried to reset phone without success on multiple occasions. Phone finally was able to be reset after about 30 minutes of trying.
This needs to be corrected

Just happened to me as well. It also prevented me from connecting to itunes. I found this thread after looking up if this was a common problem and yeah turns out i wasn’t the only one. To reset iPhone press volume up, press volume down and press and hold power button. only hold the power button not all three.

1 Like

This just happened to me also and I accidentally called 911, the iPhone reset trick worked, thanks!

Same issue, This just happened to me. Nothing is working to unlock

https://support.apple.com/en-us/HT201412 ( * iPhone 8 or later: Press and quickly release the Volume Up button. Press and quickly release the Volume Down button. Then press and hold the Side button until you see the Apple logo.)

happened to me to, with the cops as well :sweat_smile:
this is one crazy

This just happened to me today.

This seems like a very serious bug…

Causing people to call emergency services because the app locked up the phone, could have bad liability issues for a company whose products have worked really well for me, up until this issue…

The same happened to me today, but I was not as lucky as you, as I still unable to restart my iPhone. When I tried to shut the iPhone down, it called 911 and the police came. What I have is a blue screen on my iPhone 12 with the words Eufy Security on it. And it is frozen and does not allow even forced restart of iPhone (sound up, sound down, side button), and does not allow switching to settings or to any other app. Could anyone advise what to do? Thanks in advance.

Probably change your iPhone, if you volume up and down and keep finger on power button till you see Apple logo then it’s rebooting, if not there’s something wrong with phone ?

Me too. iPhone 12s