EUFY Security App v4.0.1_1206(EU) "Problems"

EUFY Security App Nightmare

This lastest update has caused mega problems.
Lost all cameras and homebase from the android app ,

Keeps shutting down / logging out when closing the app and now need to use an authentication capcha code when logging back into the app.

When trying to share devices the recipients do not get an “accept” within the app.

This update is a shambles and cannot have been tested properly by the developers.
From a simple easy to use app, you have now released an untested, unreliable, updated version that has cause numerous issues.

Please give us a way of reverting the app back to earlier versions.

10 Likes

That and firmware!

1 Like

You can get older versions of the app from Apkmirror.com. They have versions going back over a year. I typically use this site to download apps that I use with Bluestacks. Never had any issues with the apks I have downloaded. You do have to be careful when selecting the apk version you want. They generally give you a choice of at least 2 versions of the same file. You want to make sure you don’t download the one that says “Bundle” or you will get a lot of other crap along with the file you want. As long as you download the Non-Bundle file, you will get the same file you would get from Google Play.

Anyone else has lost the ability to use fingerprint? I disabled it once to login with password and now can’t get it back even with reinstall

1 Like

Yes, same issue here. The app logout each time I close it. I have to renter my (long) password each time I open the app, which is painful. Hopefully, this will get fixes soon.

4 Likes

I contacted the support but have yet to hear back. Hope to they resolve this soon.

3 Likes

Are we supposed to add home base and cameras back? This v.40 update caused me mental stress. I don’t need this crap with stooped ppl. This is a crock of shit I’ve lost everything. Now I have to go out takeoff the cameras off the solar panels bring them inside to add back to the home base the whole purpose of buying solar panels was so I wouldn’t have to charge them again I never get them back in the same place for security. Idiot’s

Your devices are still there, just go to the top left of the main app page and hit the arrow to the right of the account names home. This will bring up Shared Devices. Select that and your devices should reappear. Poor design from really lame software developers.

I never had the feature of shared devices to choose from. I had to go back and add my home base and cameras and I lost all of my videos.

Soooo annoying. Login every time with “make sure you are not a robot” crap and then there is the issue where my wife lost all the access as a guest to the cameras everything just disappeared. There is no way to get it back no matter what tricks we tried. Tried older tricks from other people from the past with no luck. F you eufy i f hate this… no really like wtf how can you f up so bad with one update that I did not agree on and didn’t ask for.

I’m having the same issue, I recently updated the app, and I started having problems, my wife also updated it and she has the same problem as me, the notifications stopped arriving, and when they arrive they are 30 and 40 minutes delayed, I reported to eufy I hope they can fix this ASAP.

Anyone lost the ability to see videos for ring events? I am on IOS 15 and the videos are not appearing in the app anymore.

Same problem here. No issues in the past. Since the last update it’s horrible.

Revert back to previous version and get rid of latest version 4 trash

Download link doesn’t work for me for some reason?

went through the download process but can’t open or access the download!
REALLY don’t like the v4.0.1!! or the fact that it updated without my knowledge!

since setting all changed I accidentally took my homebase off line and now I can’t get it back!! I can’t access anything on the app .
I have gone thru all the unplugging and re-pluggng of leads and refreshing etc but still NOTHING!!!

Ever since updating today from the Apple App Store, my wife and I keep getting “kicked out.” We have to start at square one and set up and then do an Invite for the other. Then when one of us goes into the App, it deletes the other user. All worked well until v4.0.1. This app needs some serious work.

Downgrade back to version 3.5.1. The link is in one of the threads or contact live chat. However I had to retrieve it from the emailed transcript as it wouldn’t work via the live chat. I’m now enjoying the WORKING eufy system again

I have so far blocked the Eufy update from playstore because of all the problems and I am still on v3 and will remain there because at least I know the old system worked, you would have thought Eufy would have really checked that v4 worked before pushing it out to customers but as usual Eufy do not care about us all they want to do is sell more products without supporting them.