Eufy Video Doorbell p2p connection failure

This evening i started having issues with my door bell , I am getting motion alerts via the app however when I try to view the clip or connect to live view I get an error.

Unable to connect to video doorbell (P2P Connection failure)…

I have removed the app and reinstalled , but still the same. Restarted Homebase but no change.

When i now go to homebase settings , i get “Faield to request .-23”

Got exactly the same issue this evening. Possibly eufy servers having issues?

Just noticed something strange , It works fine from Android but shows this error message on IOS

If it works on Android, then it wouldn’t be a Eufy server issue. Is your IOS app the latest version?

I’m getting the same and none of my cameras are connecting with my iPad or iPhone - could it be Apple security update?

I have been dealing with this issue on and off for about 4 months. I thought it could be a Eufy device issue as I have three (3) Eufycam 2C cameras attached to the same Homebase that have worked fine throughout. Doorbell was updated in December and the issue went away. About 2 weeks ago I started getting an error saying that the Doorbell was offline. But it was still recording events and I could view them. Go figure. Then a couple days ago it stopped recording completely. This morning I tried re-syncing the doorbell. Did it 3 times now. It recognizes the doorbell, but I am now getting the P2P Connection Failure message again and it won’t detect or record events. Other cameras are still working fine. VERY frustrating. Finally asked Eufy Tech Support to send new doorbell as I am at my wits end trying to make this one work.

Exact the same problems

The same problems too. My second doorbell is working fine.

Solved! The same problem. Switch off 2FA and is works fine. (Accountsettings)

Am also getting the same issue and it is saying to contact custom services. And am not sure whom to call as am in Australia and there is no Australian number to contact.

Hi, I have just been installing my doorbell and had this repeated P2P issue. Every-time I clicked the doorbell into place I would get the P2P issue and the doorbell would usually disconnect and I would need to go through the set up again. On one occasion when I installed the doorbell I heard a beep, and identified that the screw head used to secure the mount to my wall actually came into contact with the sync button on the doorbell. I altered the fastners I used and ensured that the countersunk head of the screws were level with the mount (the ones supplied are really poor so threw those straight in the bin). Went through the set up again and the doorbell now works ok (finger crossed) - maybe worth checking/trying if recently installed.

I also switched two factor authentication off.

I’ve narrowed the p2p connection problem down to the wifi channel settings on my router. If my router is set to optimise the channel and use 20, 40 or 80 MHz then the eufy 2K wired doorbell occasionally drops out with the p2p connection error. When I disable wifi channel optimisation and only use 20 MHz then it reconnects instantly.

FWIW, I had the same problem (wired doorbell not connecting anymore), after replacing my router.
I was able to track it down to a setting in my Router (ASUS). The router is able to intercept and answer ntp queries from the internal network (i.e. UDP/123). After turning that off, the doorbell works again.

After escalation, eufy support stated that the wired doorbell utilizes “random UDP ports for P2P connections”. I find it weird, to use a port with a defined protocol and I’m not really sure whether I understand or believe this. But fact is, after turning off ntp interception on the “Administration->System” tab, functionality is restored.