Eufy2c alarm keeps going off

Hi, so last night around 3am the alarms on my eufy 2c cameras started sounding for no reason (alarm is disabled on both on the app under Home and Away so shouldn’t sound). There had been no motion detected either, regardless of the fact the alarms are disabled. Anyway in the end, not to annoy neighbours with the sound, I switched both cameras off. This morning I put them both back on and every so often the alarm keeps going off again (despite still being disabled on the app). I switched the cameras off yet again as it is annoying. But then one camera’s alarm even went off an hour or so later even though the camera is supposedly off! Anyone any suggestions to help? Thanks in advance.

Try resetting the homebase, maybe the homebase is messed up a bit.

Thanks John0. When I reset the homebase, will I need to add the cameras back on (as in will it wipe all data and connected devices?). Thanks

Yea, it starts off clean again.
I take it you tried turning off the power on the homebase?

Just to make sure, the eufycam 2c has no anti theft alarm, correct? If it does, see if it is enabled/disabled in the settings. Erratic movement can cause it to go off as it detects it is being moved.

Mine did the same last night. Has your problem stopped?

Mine has just done the same thing twice around 3am, same settings etc. Can anyone else add to this?

I’ve had the same issue. Only had it set up a few days and today it has started intermittently sounding its alarm. No notifications of any sort and nothing obvious in the app.
Cameras haven’t been moved.
I’m wondering if it is trying to alert us to connectivity issues between the base unit and the cameras.

Does it still sound if you de-activate the anti-theft detection?

goto app
click on 3 stripes top left
click on camera
anti-theft detection

Would help narrow the cause of the issue somewhat

My cameras are doing the same. It appears to be at night every 3 hrs starting at 9pm. I’m going to have to take them down and contact Eufy. If they don’t have a solution I’ll send them back as I’ve only had them a week

Eufy confirmed that there is no alarm that will sound if the camera is out of WiFi range. I even experimented by walking up the street a few times with the camera. Seems odd that the alarm only goes off at night. The alarm has always been turned off on the cameras and now I’ve turned the alarm sound off on the base unit too, I’ll see if that helps.

Mine also started to go off in the night, with no reason. The 2c camera has no anti theft mode. The system was set to record videos, and notifications but no alarms. No video was recorded, nor any notification but it’s alarm went off. It seems a bug to me.

Any lucky with this issue anyone? Mine just went off too. Same issue