FloodCam Pro 2 Offline Issues

Hello all,

Has anybody had any issues with the FloodCam Pro 2 going offline within 24 hours of connecting/initialising?

I recently installed 2 of these and followed the installation procedure without any issues.

The cameras worked perfectly until they went offline on my Eufy app (Android).

When I tried searching for my wifi network on my Eufy app to reconnect to it would not populate in the available wifi list.

I did a quick Google search and saw some topics about the FLC2 Pro only being able to connect to a 2.4GHz network.

Apparently some modems will try to optimise the devices that are connected to it by automatically switching them to a 5GHz network if available.

So I entered into my modem/network menu and activated a dedicated 2.4GHz guest profile for one of my FloodCams to connect to.

The other FloodCam I needed to physically reset my modem for it to become visible on the Eufy app.

So one FloodCam is connected to the new dedicated 2.4GHz network and the other FloodCam is connected to my normal network.

They have gone offline again only roughly after 24 hours.

I’ve noticed the LED is flashing red which means booting up or connection issue.

The Floodlight component still functions as it should and turns on if it senses any motion.

Does anybody have experience or knowledge that can share to resolve this issue?

Thanks in Advance!

1 Like

My FloodCam Pro 2 has gone offline probably once or twice but rebooting my router so far has taken care of the issue. I’ve had the same offline issue with my SmartLock and knock on wood rebooting has so far been successful.

I’m having a similar issue. I don’t know how to solve it