Geofencing does not work at all

Seems to work for me most of the time. Left for work this morning as as soon as I left the geofencing zone the system notified me it had armed. Sometimes it’s a little slow to respond, but I think that’s a location refresh problem in the phone as opposed to the app itself. The best you can do is make sure the Eufy app has access to the location all the time, and no power restrictions.

It’s absolute rubbish on iOS. Quite possibly the worst integration of any feature on any app I own.

1 Like

I seem to have got mine working I switched it to the medium radius on my iPhone and it improved left my partner’s iPhone on small that still played up
So in the end I switched them both to the large radius and it’s been working fine for two days now switching in and out fine no more phone unavailable or waiting.
Large radius looks to be about 500m so not to far from home
Hope this will work for others​:grin::grin:

I have the same issue. Had a set of 2C’s and they wouldn’t specifically disarm when I came home. So annoying. After 6 months of use and false alarms I added one camera to Homekit and the geofencing feature worked flawlessly, Have the front and rear cameras setup just to record any movement now. Very pissed off with EUFY with this but, to be honest I think this is an  issue that they restricted it. Worked 95% of the time when I was on iOS13. Using 2K ones now and still exhibiting the same issue. Great camera apart from this feature and one of the only ones that don’t require a subscription. Love that feature that all my recordings stay on the Homebase and never reach the cloud. Ran snoop diagnostics and the from what I see the send info up and down but no packets of size that would indicate recording.

1 Like

Same issues here! When I initially started with just two 2k pan & tilt geofencing worked, well in a fashion it did, way better than now. a
I now have seven (7) 2k pan & tilt & six (6) 2c external.
Despite spending hours (more like days) checking EVERY setting it is abysmal. I’ve gone through everything multiple times over.
Still geofencing is so unreliable. On rare occasions it does work after extensive delays but it still says away for various extended times when I arrive (walk} home (or home when away) . I’ve tried small to large zones but no change.
I’m certainly not happy that I’ve wasted around $3,500 on this system.
Of interest when I check, some cameras show Away & others show Home.
Another issue is the external cameras clearly detect (red LED) but NOTHING is recorded, they seem to be in a sleep mode.
I use Android on a Samsung S21.

Same conditions as original poster here.

Geofencing never worked in their app. All answers of Eufy only with standard sentences. Nothing helped. All other GPS / geofencing apps are running well.

This is a situation over 1 year and all of their app updates mentioned never ever something in association with geofencing improvements. So it seems they are absolutely NOT interested.

1 Like

i had the same experience, sad!

I am now looking for another solution that also works with an alarm system.

Peter

1 Like

I have exactly the same problem.

It only works when I disable power saving for the Eufy app… But it drains a lot of battery. On my wife’s older phone 30%!

Please fix this

1 Like

Yeah, this is (one) issue I have w/ these eufy cameras too. It’s been very clumsy in many areas, but the Geofencing failure is really the tipping point. Considering this original post came from Nov 2020 (now Aug 2021) and there’s been no real support from eufy, I’m within my 30 days purchase window to return these for a refund.

I chose eufy over the Arlo’s because of the HomeKit Secure Video option and no subscription…but that means nothing if the cameras cannot provide the basic function of true secure monitoring!

Mismo problema. Geovallado no funciona. Es una lástima, pero un verdadero problema llegar a casa conduciendo y tener que usar el móvil para quitar la alarma antes de poder abrir el garaje.
La aplicación siempre la dejo abierta en segundo plano pero no funciona, hace un poco lo que le viene en gana.

Hi There, I have been watching these forums for well over a year now waiting to see if there is a fix for the Geofencing. I have an iPhone 12 pro max and only have the system setup on my phone. Removed it from my wife’s phone due to never working. The issue I have is when I leave home, it does active, but it never resets to HOME mode when I get home. The app is running in the background, but only when I open the app, will it then change to HOME mode. Running in the background does not work. My good friend also bought the same system as me, and he too is having exactly the same problem so it is obviously not an environmental issue or phone issue but is a EUFY problem. I am getting fed up with the condescending automated response emails from EUFY stating they are sorry… if they were sorry, they would have it fixed or had a recall and stopped selling them until it was fixed. The system itself works great, just the Geofencing which a lot of people, including myself, switched from Arlo or other systems due to the advertised Geofencing “capability”.
I have stopped sending messages to EUFY, as it is not working and just gets me worked up. Just wanted to say something today in case someone has found a fix, other than using Google or Alexa as this defeats the purpose of having it automated.

Exact same issue as the user above me. What’s especially frustrating is that geofencing worked perfectly for the first few weeks I had the camera, then just abruptly stopped for no reason. It still accurately tracks my position and triggers away mode when I leave, but does not trigger home mode when I return. This used to work flawlessly. I’ve even switched to a newer phone and there’s been a major iOS upgrade after this feature broke, neither of which have rectified things, which indicate this is entirely a Eufy problem and not a phone/OS problem. Further frustrating is that if I do return home and open the app, the map pin and radius correctly shows that I’m home, but if I check the status of my device in the app, it says it’s “not in the zone”, which is a lie. Only after about 30–60 seconds of the app remaining open and on screen does the status finally update to home.

I had the same issue (2 devices with separate logins) with arlo for over 1 year before they fixed it.
So seems not to be the most simple task.

With eufy I had to abandon it completely. Even with just one device, my phone being the only one it did not turn on nor off the cameras. Very unreliable so I just put the eufy cams I have (7 of them) in places that need survaillance all the time and just have them on at all times and then use 4 arlo for the spots heavy trafficed and therefore needs geo fencing not to drain battery to quick.

I wish I could schedule eufy to send or not send push aswell. To bad that is only on the camera setting and not in the security settings.

Exactly the same issue here. Me and my wife set up our phones for geofencing and it appears to either not be updating at all or showing incorrect states (out of area or unavailable). Horrible

Exact same issue too with Android phone. App says phone not in zone but on the map it is right in the center… And no way to make it work again.
It worked well for a few months and since 2 months it became unusable and I switched to manual mode…
Eufy, please wake up !

Does eufy has any intentions of fixing this at all? Calling a feature as beta for eternity does not give you a free pass.

1 Like

I have the same problem

Same problem for me, one of the reasons I purchased was the Geofencing but it doesn’t work. I’ll be returning my product.

For me Geofencing works when coming in my home, but it does not work when leaving my home. I have to go to the iOS App. Then it works.

I tested this and sometimes work in my iPhone and sometimes not. Usually it works ok but it is not very reliable. I don’t know why