Homebase 2 won’t connect through Ethernet cable during initial set up

I’m quite literally stuck on the first step and I need help before I lose my marbles

I have a Netgear Nighthawk router that’s dual band
I’ve attempted to turn off the 5ghz/restart router and see if the homebase 2 will then connect but it doesn’t
It’s not even recognising that it’s plugged in to the router
I’m unable to temporarily disable to firewall on my router as it’s not as simple using the netgear router login
I have made sure the DHCP is turned on and I’ve made sure that TCP 443 and 80 and on and when I tried to correct the UDP it says it’s unable to go past ‘65534’. I’ve found one help thread where the EUFY team has responded and said the UDP needs to be 0~65535 but I physically can’t change the setting to that high

So now what? I feel like I’ve just wasted over $300 on something that won’t work

I have that exact same router and have had no issues with using it with my Eufy gear.

If you cannot connect to ethernet, turning off 5 Ghz won’t solve your issue and its not necessary.

Unless you have custom settings, the Homebase should connect with out of the box settings. The only thing I can think might prevent ethernet is if you have Access Control set to “Block New Devices”. In the case, you need to either add the Homebase MAC address to your allowed list or turn off Access Control.