SmartDrop Firmware Update Failing - v1.3.1.5

I was so happy to see a firmware update this morning as my battery has been discharging every day. I was hoping this would fix that issue along with Motion Detection settings automatically resetting, Notification options, and the originally promised HomeBase integration.

The update form v1.3.0.3 to v1.3.1.5 failed. I walked through all their in-app “debugging” steps, but SmartDrop was completely frozen. I could only get it back to a known state be deleting SmartDrop from the app, removing the battery, and then re-adding SmartDrop.

After 3 firmware updates (which take about 10 minutes!), it still failed and reverted back to the original v1.3.0.3. Was anyone successful? Any hints you could throw to others?

Thanks!
Mike

Yesterday while at work, the firmware magically updated to v1.3.1.5. It took about 2 weeks, but somehow it just updated. Unfortunately, it did not seem to fix the issues I described above. I now see a feature where you can add the HomeBase to save recordings locally, but when clicking on it, it states that “HomeBase” must be updated by contacting support. I reached out to support last night, but have not heard back. No auto-firmware updates seem to be available for the HomeBase 2.

Interestingly, last night, the SmartDrop tried to update to v1.3.2.0. Guess what? It crapped-out and locked-up just like the previous version. I’ve tried updating several times, but again no luck. Wow, this is painful. I’ll keep charging the battery daily and hope for the best over the next few weeks.


One other issue that got introduced is that the SmartDrop goes in to this “Updating…” state. Not sure what this is about, but it lasts for about 30 seconds and keeps repeating every few minutes. It’s basically unresponsive during these “updating…” sessions. Also, I can no longer input any “Delivery PINs”. I enter the name of the delivery service, select the PIN length, and then it pops me back to the main “Delivery PIN” menu.

I’ll post updates as I have them. If anyone else has a SmartDrop, please post your experience as well. Thanks.

After about 10 more days, system finally updated to 1.3.2.0. Though, I can’t say it fixed any issues I was having. And, it introduced one big problem - the devices goes offline every night. I must open the box, remove the battery, put the battery back in, and then I am good for another 24 hours. …and, repeat daily. Aaaaargh!

No more firmware updates in the meantime. I did have a small update to HomeBase 2, but that did not fix any integration issues with SmartDrop. I will followup on those details in another post later.