Unable to Name Device

Trying to set up a new 1080 doorbell. All ok on the Chime until it prompts to name the device but each I try gives the error ‘Set failed’ so I can’t continue.
Tried a variety of names such as Chime, EufyChime, FrontDoor,etc but all fail.
Can anyone help please?

We had this trouble too. We exited/accepted then went to home and there was an autoname assigned. We were able to change it then.

Seems like a bug that needs to get fixed.

Thanks for responding but could I clarify. Did you have to cancel the setup to get back to Home then start again?

Eufy did have a version of the Android app that wouldn’t accept spaces or special characters in names at one point. This was fixed in an app update several months ago. Make sure you have a current app to avoid any issues.

That’s interesting, I did have an error when I tried a name with spaces though weird as I only downloaded it from Google Play a few days ago. I’ve raised a call with Eufy support but not had much constructive help yet. So far they’ve suggested it’s a problem with my wifi (which is fine) & suggested I skip past this point in the setup which I have no option to do. All a bit frustrating tbh

I just tried and sucessfully renamed one of my cams. I am on Android version 3.3.41107(US). Sometimes Eufy fixes things then breaks them in later releases, but didn’t see any issues this time.

I have version 3.3.41107 too. Still waiting on advice from Eufy unfortunately as the only option I have available is to cancel the setup