Unable to play live video problem outside home network

Hi,

I have 3pcs Eufycam 2 pro cameras , 2k doorbell camera connected to homebase2.
2pcs indoor camera witch are connected straight to wifi.
All works great when I’m home wifi. But outside the home network is painful to get connect to any off those cameras. I have great 4G connection at my iPhone 12 Pro max but when try to open camera I see first “establishing secure video channel and after that, unable to play live video.” I need to reconnect at least 5-10 times to get successful connection. Many times takes 20 reconnection to get live stream open.
Connection between camera and home base are great. Wifi connection to indoor camera are great. At wifi connection works always and fast but no outside home network. When using guest wifi outside home connection is better than using 4G, but not work always.

I have set every camera video stream quality to auto/poor but that’s not help.
Notification at doorbell camera works great, but when it takes 5-15min to get live stream or see record what is the point whole notification and products ?

Same problem are when try to view recording at 4G but that works little bit often than live stream

Before these cameras I have Logi circle cameras and those works great and I get instant live view no matter if I was home or outside networks. So I thing that problem is your cloud service or whatever connection that app use.

Other problem is geofencing, That not works at all. Sometimes mode changes instantly when come or leave area, sometimes takes 30min, sometimes have to change mode manually.

2 Likes

I have the same problem with my doorbell through WiFi there’s no problem but on 4G with different iPhone there isn’t any contact.

This is in my eyes since the last update there is a problem that is blocking outside communication.

1 Like

Other people here and on Reddit have had similar problems, but its not a firmware issue or everyone would be having trouble. It could be your ISP or firewall blocking either the video stream or the metadata that get sent to AWS to tell your phone where to get the stream. Does the Eufy Web Portal work for your system?

Web Portal

HI,

I have the exact same problem with the Eufy 2K camera (I see first “establishing secure video channel" and after that, unable to play live video.”). With the Wi-Fi connection without problems but with the 4G connection it does not reproduce, very rarely I get it. In the web portal it always reproduces correctly.
IPhone X IOS 15 (Beta RC)
Eufy IndoorCam P24 2K (firm 2.1.0.4)

@DarkEvilRivas Sounds like the issue has to do with your Iphone since the web portal works. That means the stream address metadata and connection from your router are working. There have been several posts about the same issue and most seem to happen with IOS. If you are on a Beta release of IOS, I don’t know what to tell you. It seems to me that someone fixed this problem by editing their APN so it used IPv4 instead of IPv6. You might try searching here and on Reddit for posts about this problem.

If you don’t have any luck, try to contact Eufy support by email. The phone and chat people seem to be just script readers and usually are no help. Sending an email ensures a ticket is created and might get you a solution.

Same here, I have the problem, too! I have the Eufy 2K in another apartment. Internetconnection is normaly fine and I hadnt issues until today. My iPhone X is connected to another WiFi in another town, but Im not able to connect anymore. Until today, it worked perfect. I tried normal LTE with my phone, too, but no response. And i tried it on the Computer. …“The camera is offline”. :frowning: I´m not able to drive multiple hours to the eufy-cam to reset it… I hope thats a server-issue and I hope it will be fixed in the next hours without requiring me to drive there and reset it…

This is a chaos. You can see more cases in the forum:

I have the same problem as the initial post states. It just started happening about 2-3 weeks ago. Nothing changed on my side of things. Same phone, same equipment, same everything. I thought it might be a firmware upgrade or something but from what I’m reading that does not appear to be the case.