Unable to connect to Homebase (-3)

I just got 4 indoorcam and was excited to show my wife how it looks when we’re not home by turning off the wifi and I too got the same issue. Any resolution to this yet? Thanks!

I’m unable to pair my eufy doorbell with home base 2

I got this unable to connect to home base (-3), ended up being a issue on from my ISP and not an issue with the cameras or maybe not even Eufy although there might be a easy fix if they read this? I have Eufy pro cam with home base security system at a warehouse on spectrum 250 mg connection, works flawlessly everywhere I go except when I access it from my wifi at my home or a few other select wifi networks. if I turn off my wifi and use my cell phone data it works just fine but the min I put my cell back on my wifi at my house I can not access the cameras at may warehouse and get the " Unable to connect to home base" message but I only get alerts via the app. It would appear it has to do with the packet size our ISP hands out on my home wifi. My IT guy is looking for a work around and I hope he finds one or Eufy can look into this closer… we use exclusively Microtik routers at the home wifi and ubiquity AP

Eufy can you explore a option to allow your system to had out non standard sized packets? Or maybe this triggers another idea you could look into?

2 Likes

@brent39

This is very interesting to me because I also have Spectrum as my ISP so I’m hoping that your IT guy can figure it out. I’ve tried talking to both Eufy support via email and Linksys tech 2 support over the phone about my Velop mesh system. Neither has given me a solution yet.
My issue has to do with my iOS Eufy app not being able to add devices such as my factory reset Homebase 2 or my Eufy 2C cameras using my active Velop mesh system on my working Homebase 2 or making changes in the settings of the working 2C cameras such as changing the activity zones, motion detection sensitivity, etc. because I get the unable to connect to Homebase (-3) error message. The cameras and the Homebase 2 just cannot communicate with each other. The working Homebase 2 cannot load the updates from Eufy. I can get live streaming over my Spectrum home WiFi and using my cellular connection.
If I use use my old ASUS router (that’s no longer supported by ASUS) everything works as it should.
Every other device I have on my Velop mesh system works fine whether I use the LAN side or the WLAN side. I’ve been dealing with this since the end of September.
I would be interested to hear in more detail about how the packets are effecting the process. Does it have to do with ipv4 or ipv6 and whether one or the other have to have the settings adjusted?

1 Like

Interesting to me too. I also have a Linksys Velop router and am having issues connecting using cellular. When on the LAN everything works flawlessly.
I have contacted Eufy support asking if I need to configure the router and they asked me to supply the make and model. I was anticipating a port range forwarding rule might need to be setup, I hadn’t even considered packet size!

Can you try Repairing, the Formatting the memory? It seemed to help on my systems.

@dombi

Thank you. I think I’ve tried that, but I’ll give it a shot again. It couldn’t hurt.

Update: I repaired the storage on the HB2 and reformatted it but I still get the unable to connect to the Homebase (-3) error message.

1 Like

I experience -3 error almost EVERY time I connect from remote to homebase2 (I have two of them that I bought recently and receive normal firmware updates, togeter with 3 cameras 2C and a battery doorbell). I connect wheneer I receive an alert and this may happen 3-10 times per day and only in very rare case the connection happens immediately.

It seems to me that the homebase has to “wake up” in 2-3 minutes before answering. Is it a power saving techinque or a time needed to setup services in the cloud ? In any case this is very annoying especially for the the doorbel as the people at the entrance go away after 3 seconds and there is no way to receive an alert before 20-30 seconds. Can you please explain why there are such delays?

Thanks.

@giorgi1
I’m not exactly sure this is what you might need to do if you have an Android phone but it might be worth looking into.

There ae two other Andoid settings that might help this problem.

Under Settings, go to Apps & notifications | App Info | Eufy Security

Under Data Usage make sure that Background data is Turned On.

Also, Turn On Unestricted data Usage.

The last setting might help speed things up if you have Data Saver turned on.

1 Like

Greetings all, I am in the same boat.
have the separate doorbell, then three exterior cams connected to the homebase.

About a month ago, I tried to access the cams from work, while on cell service. I could not. Just get the (-3) error noted above. I get all the notifications from all cams, but once I try to connect, nothing. If at home, on the home wifi, I can access everything. Honestly, if I have to go a reset all of these, I am just going to sell the system and go with something else. There have been no changes to our setup that I am aware of. And, since the cams work fine through the wifi, it does not sound like a problem with the cams, but with the Homebase.

Here is a work around I have found. the unable to connect to home base is indeed your (I should say mine for sure) ISP or Internet service provider issue. Our internet provider at our home will not open up the firewall to allow the Eufy app to communicate to offsite home bases or cameras. How I figured it out was I bought another home base and camera to play with at my personal home. I was able to use the app like I should when I was on the same wifi at the same location as my house base and camera. However if I turned off WIFI on my phone I lost the ability to connect to my new home base and cameras were not responding. So I added the home base to Apple Home kit. Now I can access all my cameras at multiple places any time regardless of what ISP I am on or wifi. Works like a charm. It requires Apple TV or a home kit hub to work at each location. So if you have a home in say Texas and a home in Washington or a warehouse in my case you will need an Apple TV at each location set up as a home kit hub. We already had one for home automation and another apple tv hub for our warehouse lights.

You will now access the cameras through your Apple Home kit app that is on your iPhone and not use the Eufy app anymore to see live streams

You will want to keep the Eufy app on your phone or tablet as there are settings on that app that the home kit won’t allow access to. Conversely there are awesome settings in home kit that Eufy app doesn’t have either. When making changes using the Eufy app you will need to be off your wifi network that is blocking and giving you a “Unable to connect” or unable to connect to home base

You will need to buy a storage plan if you have a lot of cameras from apple but its not that much coin. Also you will get double alerts when the cameras are triggered, one from home kit and one from Eufy. it was annoying but the work around again was easy… Simply open the Eufy app, select the “Security badge” and adjust the app to not allow push notifications on each camera you have through the Eufy app. This set up now works flawless and seems very robust now. Hope this helps the community. This Is a Ghetto work around for sure I wish the ISP or Eufy could work out a VPN / Cloud base or some kind of compromise but for now this is the best solution I could find

2 Likes

I had the same connection issue, What worked for me was connecting my phone to my non “GUEST” WIFI SSID. I have 2 SSID 1. for Guest and 2nd for my network devices. If you have only one SSID for WIFI and the guest option is on, try turning it off and reconnect.

1 Like

I can’t get my two cameras to connect to the base station even 8 feet away in the same room, let alone placing the cameras where I need them. I advised Eufy about the problem after having them a couple of months trying different positions etc and they replaced a camera. Still no good but by then 12 months were up and I was told I was out of the warranty period by a few days. That stinks. The equipment stinks. They offered me a discount on another base station! Why would I pay good money after bad? Customer service stinks. Eufy needs to look after their customers.

Glad I found this thread and will follow the issue here. I have the same issue

Have a slow adsl modem to homebase 2 with 4 eufy 2c cameras thar work perfect. Now the ISP will close down that service and sent a ZTE 4G router instead. Connected with ipv4. Speed is very fast conpared to old setup but connected to the 4G net with the router I can not change any settings on any camera or switch modes. I can however instantly stream all cameras with super quality and see old recordings. Ive tested on ios app with wifi or 4G with same result. Is it not odd that streaming works fine but something lile changinf name of a camera or changing motion sensitivity does not.

Ports 80 and 443 that are eufys main ports are wide open on UDP in the firewall of the ZTE router. That does not matter.

I will try to make the isp allow me to get ipv6 and see if that makes any difference and try a better router that can fragment or bugger packages to the homebase2.

Anyone in here made the -3 error go away and how did you? (Except the homekit solution I am not so willing to try)

Had same issue. What fixed it for me was enabling WiFi on the Homebase. I have no idea why this worked, since the ethernet connection is also detected. I can also then disable WiFi and it keeps working, so enabling WiFi must reset something on the Homebase that is locking up.

I am getting the same (-3) error, but it’s only for ONE of my Eufy cams. I have 5 of the battery cams paired to the Eufy HomeBase 2… but it’s just that single cam that just stopped responding out-of-the-blue. All other cams are fine. It’s got 100% battery (connected to the solar charger)… and has been working all up until last night. Sadly, there’s no way to remotely “reboot” the cameras. And yes, everything has the latest firmware updates; cams, homeBase, doorbell, etc.

Perplexed.

[EDIT]: I have tried rebooting the HomeBase, reformatting the HomeBase storage, “repairing” the HomeBase, killing the power and restarting it… also (just to try) restarted my WiFi router… and most of those things have been done numerous times. Still no change in ability to access that single camera. Range is not the issue… other cams are further away. And as mentioned above, it had been working flawlessly up until last night.