Eufy Family & Guest sharing problem

I added my dad in the Family and guest. It that the accept button will be in app but no Accept button is showing up.

2 Likes

He needs to have his own account! Once he has that he needs to go under his account in settings and accept or verify through email. I hope this helps :smiley:


This is what the email says to do. But i did not see the accept invitation message in the app. I already did twice. Same result.

Ok! Well Delete the App re-download and login once more…

Still nothing. :frowning: I’ve read that this is an issue for other users before. I think they still haven’t fix this yet.

Same problem here too, still not there

Cant get my wife or son on as administrator or guest…had to take down all the camera’s and now I’m going to reset home base and try again. … will let you know.

For all of you who are having issues with adding family members, when you send the invite email to them…

  1. make sure it is there email separate from the main account email
  2. They have to create their own eufy security account using their own email address
  3. Once they create their own eufy security account they need to log in with their account and if they already have an account have them log out and then log back in after the invite was sent.

This is what they will see after the invite was sent and they either log in or log out and back in in order to see It. The pop up asking to accept the invite

It is not that hard to add family members provided you follow the steps in the email.

If they do no have an account they will see this email informing then to download the app and register their account.

However, if they do have an account they will get this email. If refreshing doesn’t bring up the invite, logging out and back in will.

2 Likes

Thanks Tank that’s what I was trying to say. Your deeper instruction is well done… Be safe all :v:t3:

You say it’s not hard but the feature doesn’t seem to be working. I’ve lost count of the amount of invites I’ve sent to my partner and how many times we’ve uninstalled / installed / logged in / logged out / refreshed the app homepage

4 Likes

I have the same issue. The only email I get asks to download the app, so the system does not recognize I already have an account. I tried all these instructions, logged out, deleted the app, reinstalled and I even tried creating a brand new account with a different email. Nothing, no email telling me to go to the app to accept and no pop up in the app. Very annoying.

3 Likes

same here, no accept button when logging into the app with the new account.
although I truly believe @Tank description is how it is suppose to happen, it doesn’t.
Only the mail is received where I’m asked to download the app and register an account in the app.

So it seems eufy is not recognising my new account (yet?). I don’t get the mail asking to go to my app, click the accept button or refresh the app homepage. I only get the mail with the download appstore / google play buttons

Might be a possible fix. Reply I made on another topic.

1 Like

Thanks for this, will check on it :slight_smile:

Hi Marc,
I seem to be in the same situation: my partner has EU, I have US.
How did you manage to fix this / work around it?

Thanks for the instructions. Unfortunately, it doesn’t work for me. I am the Admin, I share with my wife, she has created an account. She has signed in (out, back in, multiple times) … but there is no invite to accept. All she sees is the “Add Device” screen. I have deleted her invitation and created a new one, repeated the process, but still not working. Basically, she has no invitation to accept.

@AnkerSupport - please can you fix this? There are multiple threads and dozens of users facing this issue.

We are having the same issue here. Already tried creating different accounts with different email addresses and still nothing. This is so frustrating. Very disappointed with this product.

I have the same. Sounds like a persistent issue and no one is taking care of it. Now going to Amazon to write a perfect review about it.

Hello isabel11
I has issue trying to invite my relatives as admin too. The reason is the account that they are created is not in the same region as your acc. Try to login with your relatives acc and click on the About option u will see the location of their acc either US or EU. Always make sure your acc and the person you want access to your cams have the same location.

I fix this issues by emailing the tech team at support@eufylife.com. I gave the tech support serial of one of my cam and tell him to set location of all of my relatives “app logins” (include gmails and hotmails acc) to US (or the location same as your acc).

Email the tech support. In the email give them the serial number of one of your product and subject of the email is Move account app location so they know what they are dealing with, then tell them to move the app account of the person u want to get access to US or EU same as the location of your acc in app.

1 Like